<!DOCTYPE html>
<!--[if IE 8]> <html class="ie ie8" lang="en-GB"> <![endif]-->
<!--[if IE 9]> <html class="ie ie9" lang="en-GB"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en-GB"> <!--<![endif]-->
<head>
<meta charset="UTF-8" />
<title>StoreDot announces patent for system to reduce EV charge times | Engine + Powertrain Technology International</title>
<meta name="apple-itunes-app" content="app-id=649959876">
<meta name="google-play-app" content="app-id=com.ukipme.magapp.enginetechnologyinternational">
<link rel="stylesheet" type="text/css" href="https://www.ukimediaevents.com/publication/css/smart-app-banner.css">
<link rel="apple-touch-icon" href="https://www.enginetechnologyinternational.com/wp-content/uploads/2018/07/engine-app.jpg">
<link rel="android-touch-icon" href="https://www.enginetechnologyinternational.com/wp-content/uploads/2018/07/engine-app.jpg">	
<meta name="author" content="UKi Media & Events">
<meta name="msvalidate.01" content="3A6BCEF025F5B3536CF9FF4F07958678" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<link rel="pingback" href="https://www.enginetechnologyinternational.com/xmlrpc.php" />
<link rel="shortcut icon" href="https://www.enginetechnologyinternational.com/wp-content/uploads/2017/11/favicon.ico" />
<script>
</script>
<!-- This site is optimized with the Yoast SEO plugin v12.3 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://www.enginetechnologyinternational.com/news/fuel-cells-technologies/storedot-announces-patent-for-system-to-reduce-ev-charge-times.html" />
<meta property="og:locale" content="en_GB" />
<meta property="og:type" content="article" />
<meta property="og:title" content="StoreDot announces patent for system to reduce EV charge times | Engine + Powertrain Technology International" />
<meta property="og:description" content="StoreDot, a producer of extreme fast charging (XFC) battery technology for EVs, has announced a system that it claims will significantly reduce EV charging times. The company says the technology will be made available to the entire market, to help expand existing charging infrastructures and speed up the world’s adoption of EVs. &#039;) } elseRead More" />
<meta property="og:url" content="https://www.enginetechnologyinternational.com/news/fuel-cells-technologies/storedot-announces-patent-for-system-to-reduce-ev-charge-times.html" />
<meta property="og:site_name" content="Engine + Powertrain Technology International" />
<meta property="article:section" content="Fuel Cell Technologies" />
<meta property="article:published_time" content="2021-08-25T11:33:26+00:00" />
<meta property="og:image" content="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/ETM-Web-August-25-StoreDot.jpg" />
<meta property="og:image:secure_url" content="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/ETM-Web-August-25-StoreDot.jpg" />
<meta property="og:image:width" content="700" />
<meta property="og:image:height" content="335" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="StoreDot, a producer of extreme fast charging (XFC) battery technology for EVs, has announced a system that it claims will significantly reduce EV charging times. The company says the technology will be made available to the entire market, to help expand existing charging infrastructures and speed up the world’s adoption of EVs. &#039;) } elseRead More" />
<meta name="twitter:title" content="StoreDot announces patent for system to reduce EV charge times | Engine + Powertrain Technology International" />
<meta name="twitter:image" content="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/ETM-Web-August-25-StoreDot.jpg" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.enginetechnologyinternational.com/#organization","name":"UKi Media & Events","url":"https://www.enginetechnologyinternational.com/","sameAs":[],"logo":{"@type":"ImageObject","@id":"https://www.enginetechnologyinternational.com/#logo","url":"https://www.enginetechnologyinternational.com/wp-content/uploads/2018/03/uki-logo.jpg","width":512,"height":401,"caption":"UKi Media & Events"},"image":{"@id":"https://www.enginetechnologyinternational.com/#logo"}},{"@type":"WebSite","@id":"https://www.enginetechnologyinternational.com/#website","url":"https://www.enginetechnologyinternational.com/","name":"Engine + Powertrain Technology International","publisher":{"@id":"https://www.enginetechnologyinternational.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://www.enginetechnologyinternational.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.enginetechnologyinternational.com/news/fuel-cells-technologies/storedot-announces-patent-for-system-to-reduce-ev-charge-times.html#primaryimage","url":"https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/ETM-Web-August-25-StoreDot.jpg","width":700,"height":335},{"@type":"WebPage","@id":"https://www.enginetechnologyinternational.com/news/fuel-cells-technologies/storedot-announces-patent-for-system-to-reduce-ev-charge-times.html#webpage","url":"https://www.enginetechnologyinternational.com/news/fuel-cells-technologies/storedot-announces-patent-for-system-to-reduce-ev-charge-times.html","inLanguage":"en-GB","name":"StoreDot announces patent for system to reduce EV charge times | Engine + Powertrain Technology International","isPartOf":{"@id":"https://www.enginetechnologyinternational.com/#website"},"primaryImageOfPage":{"@id":"https://www.enginetechnologyinternational.com/news/fuel-cells-technologies/storedot-announces-patent-for-system-to-reduce-ev-charge-times.html#primaryimage"},"datePublished":"2021-08-25T11:33:26+00:00","dateModified":"2021-08-25T11:33:26+00:00"},{"@type":"Article","@id":"https://www.enginetechnologyinternational.com/news/fuel-cells-technologies/storedot-announces-patent-for-system-to-reduce-ev-charge-times.html#article","isPartOf":{"@id":"https://www.enginetechnologyinternational.com/news/fuel-cells-technologies/storedot-announces-patent-for-system-to-reduce-ev-charge-times.html#webpage"},"author":{"@id":"https://www.enginetechnologyinternational.com/#/schema/person/cb508f52a52e48f1eb0c473c9f65d970"},"headline":"StoreDot announces patent for system to reduce EV charge times","datePublished":"2021-08-25T11:33:26+00:00","dateModified":"2021-08-25T11:33:26+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.enginetechnologyinternational.com/news/fuel-cells-technologies/storedot-announces-patent-for-system-to-reduce-ev-charge-times.html#webpage"},"publisher":{"@id":"https://www.enginetechnologyinternational.com/#organization"},"image":{"@id":"https://www.enginetechnologyinternational.com/news/fuel-cells-technologies/storedot-announces-patent-for-system-to-reduce-ev-charge-times.html#primaryimage"},"articleSection":"Electric Powertrain Technologies,Fuel Cell Technologies"},{"@type":["Person"],"@id":"https://www.enginetechnologyinternational.com/#/schema/person/cb508f52a52e48f1eb0c473c9f65d970","name":"Callum Brook-Jones","image":{"@type":"ImageObject","@id":"https://www.enginetechnologyinternational.com/#authorlogo","url":"https://secure.gravatar.com/avatar/29db26da9206fb239e36ba90e51d08d2?s=96&d=mm&r=g","caption":"Callum Brook-Jones"},"description":"After spending the past six years working as a mechanic for various motorsport and high-end performance car companies, Callum recently joined UKi Media &amp; Events as an assistant editor. In this role he will use his vast practical knowledge and passion for automotive to produce informative news pieces for multiple vehicle-related sectors.","sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="Engine + Powertrain Technology International &raquo; Feed" href="https://www.enginetechnologyinternational.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Engine + Powertrain Technology International &raquo; Comments Feed" href="https://www.enginetechnologyinternational.com/comments/feed" />
<link rel="alternate" type="text/calendar" title="Engine + Powertrain Technology International &raquo; iCal Feed" href="https://www.enginetechnologyinternational.com/events/?ical=1" />
<!-- <link rel='stylesheet' id='rs-plugin-settings-css'  href='https://www.enginetechnologyinternational.com/wp-content/plugins/revslider/public/assets/css/settings.css?ver=5.4.3.1' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//www.enginetechnologyinternational.com/wp-content/cache/wpfc-minified/240kfmta/htnqp.css" media="all"/>
<style id='rs-plugin-settings-inline-css' type='text/css'>
#rs-demo-id {}
</style>
<!-- <link rel='stylesheet' id='wp-polls-css'  href='https://www.enginetechnologyinternational.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.2' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//www.enginetechnologyinternational.com/wp-content/cache/wpfc-minified/loydq2r9/htnqp.css" media="all"/>
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
margin: 1px;
font-size: 18px;
line-height: 20px;
height: 20px;
background: #29aae2;
border: 1px solid #000000;
}
</style>
<link rel='stylesheet' id='smartmag-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C400Italic%2C600%2C700%7CRoboto+Slab%7CMerriweather%3A300italic&#038;subset' type='text/css' media='all' />
<!-- <link rel='stylesheet' id='smartmag-core-css'  href='https://www.enginetechnologyinternational.com/wp-content/themes/smartmag/style.css?ver=3.1.0' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='smartmag-responsive-css'  href='https://www.enginetechnologyinternational.com/wp-content/themes/smartmag/css/responsive.css?ver=3.1.0' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='pretty-photo-css'  href='https://www.enginetechnologyinternational.com/wp-content/themes/smartmag/css/prettyPhoto.css?ver=3.1.0' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='smartmag-font-awesome-css'  href='https://www.enginetechnologyinternational.com/wp-content/themes/smartmag/css/fontawesome/css/font-awesome.min.css?ver=3.1.0' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//www.enginetechnologyinternational.com/wp-content/cache/wpfc-minified/31nd6d9z/htnqp.css" media="all"/>
<style id='smartmag-font-awesome-inline-css' type='text/css'>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</style>
<!-- <link rel='stylesheet' id='wpbdp-widgets-css'  href='https://www.enginetechnologyinternational.com/wp-content/plugins/business-directory-plugin/assets/css/widgets.min.css?ver=5.1.7' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='jetpack_css-css'  href='https://www.enginetechnologyinternational.com/wp-content/plugins/jetpack/css/jetpack.css?ver=7.1.3' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//www.enginetechnologyinternational.com/wp-content/cache/wpfc-minified/d46tvxni/htnqp.css" media="all"/>
<script src='//www.enginetechnologyinternational.com/wp-content/cache/wpfc-minified/1nigfph1/htnqp.js' type="text/javascript"></script>
<!-- <script type='text/javascript' src='https://www.enginetechnologyinternational.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script> -->
<!-- <script type='text/javascript' src='https://www.enginetechnologyinternational.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script> -->
<!-- <script type='text/javascript' src='https://www.enginetechnologyinternational.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.tools.min.js?ver=5.4.3.1'></script> -->
<!-- <script type='text/javascript' src='https://www.enginetechnologyinternational.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.revolution.min.js?ver=5.4.3.1'></script> -->
<!-- <script type='text/javascript' src='https://www.enginetechnologyinternational.com/wp-content/plugins/wp-hide-post/public/js/wp-hide-post-public.js?ver=2.0.10'></script> -->
<!-- <script type='text/javascript' src='https://www.enginetechnologyinternational.com/wp-content/themes/smartmag/js/jquery.prettyPhoto.js?ver=ac5b09b99a0ec7d5ed3594f9ff954106'></script> -->
<link rel='https://api.w.org/' href='https://www.enginetechnologyinternational.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.enginetechnologyinternational.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.enginetechnologyinternational.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://www.enginetechnologyinternational.com/?p=10990' />
<link rel="alternate" type="application/json+oembed" href="https://www.enginetechnologyinternational.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.enginetechnologyinternational.com%2Fnews%2Ffuel-cells-technologies%2Fstoredot-announces-patent-for-system-to-reduce-ev-charge-times.html" />
<link rel="alternate" type="text/xml+oembed" href="https://www.enginetechnologyinternational.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.enginetechnologyinternational.com%2Fnews%2Ffuel-cells-technologies%2Fstoredot-announces-patent-for-system-to-reduce-ev-charge-times.html&#038;format=xml" />
<!-- Twitter Cards Meta - V 2.5.4 -->
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@SustainableICES" />
<meta name="twitter:creator" content="@SustainableICES" />
<meta name="twitter:url" content="https://www.enginetechnologyinternational.com/news/fuel-cells-technologies/storedot-announces-patent-for-system-to-reduce-ev-charge-times.html" />
<meta name="twitter:title" content="StoreDot announces patent for system to reduce EV charge times" />
<meta name="twitter:description" content="StoreDot, a producer of extreme fast charging (XFC) battery technology for EVs, has announced a system that it claims will significantly reduce EV charging [...]" />
<meta name="twitter:image" content="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/ETM-Web-August-25-StoreDot.jpg" />
<!-- Twitter Cards Meta By WPDeveloper.net -->
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://www.enginetechnologyinternational.com"><link rel="https://theeventscalendar.com/" href="https://www.enginetechnologyinternational.com/wp-json/tribe/events/v1/" /><style type='text/css'>img#wpstats{display:none}</style><meta name="generator" content="Powered by Slider Revolution 5.4.3.1 - responsive, Mobile-Friendly Slider Plugin for WordPress with comfortable drag and drop interface." />
<script type="text/javascript">function setREVStartSize(e){
try{ var i=jQuery(window).width(),t=9999,r=0,n=0,l=0,f=0,s=0,h=0;					
if(e.responsiveLevels&&(jQuery.each(e.responsiveLevels,function(e,f){f>i&&(t=r=f,l=e),i>f&&f>r&&(r=f,n=e)}),t>r&&(l=n)),f=e.gridheight[l]||e.gridheight[0]||e.gridheight,s=e.gridwidth[l]||e.gridwidth[0]||e.gridwidth,h=i/s,h=h>1?1:h,f=Math.round(h*f),"fullscreen"==e.sliderLayout){var u=(e.c.width(),jQuery(window).height());if(void 0!=e.fullScreenOffsetContainer){var c=e.fullScreenOffsetContainer.split(",");if (c) jQuery.each(c,function(e,i){u=jQuery(i).length>0?u-jQuery(i).outerHeight(!0):u}),e.fullScreenOffset.split("%").length>1&&void 0!=e.fullScreenOffset&&e.fullScreenOffset.length>0?u-=jQuery(window).height()*parseInt(e.fullScreenOffset,0)/100:void 0!=e.fullScreenOffset&&e.fullScreenOffset.length>0&&(u-=parseInt(e.fullScreenOffset,0))}f=u}else void 0!=e.minHeight&&f<e.minHeight&&(f=e.minHeight);e.c.closest(".rev_slider_wrapper").css({height:f})					
}catch(d){console.log("Failure at Presize of Slider:"+d)}
};</script>
<!-- Global Site Tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=GA_TRACKING_ID"></script>
<script>
window.dataLayer = window.dataLayer || [];
function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'UA-3611785-33');
</script>
<!-- Global site tag (gtag.js) - AdWords: 920977188 -->
<script async src="https://www.googletagmanager.com/gtag/js?id=AW-920977188"></script>
<script>
window.dataLayer = window.dataLayer || [];
function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'AW-920977188');
</script>
<meta name="msvalidate.01" content="AEB6A5E6BCFB5B30A8E4127C5F279ED8" />			<!-- <link rel="stylesheet" type="text/css" id="wp-custom-css" href="https://www.enginetechnologyinternational.com/?custom-css=bfd631e55a" /> -->
<link rel="stylesheet" type="text/css" href="//www.enginetechnologyinternational.com/wp-content/cache/wpfc-minified/kaby9756/htnqp.css" media="all"/>
<!--[if lt IE 9]>
<script src="https://www.enginetechnologyinternational.com/wp-content/themes/smartmag/js/html5.js" type="text/javascript"></script>
<![endif]-->
<script>
document.querySelector('head').innerHTML += '<style class="bunyad-img-effects-css">.main img, .main-footer img { opacity: 0; }</style>';
</script>
</head>
<body data-rsssl=1 class="post-template-default single single-post postid-10990 single-format-standard page-builder tribe-no-js tribe-bar-is-disabled smartmag right-sidebar boxed post-layout-modern img-effects has-nav-dark has-nav-full has-head-default">
<div class="wallpaper-ad">		
<div class="a-widget">
<SCRIPT LANGUAGE="javascript">
<!--
width = window.innerWidth;
console.log ('WIDTH' + width);
if (width >= 1400 && width <=1600 )  {
console.log ('wallpapera');
document.write('<ins data-revive-zoneid="41" data-revive-ct0="%c" data-revive-id="7d3eab13b195263024792b3b73763e23"></ins><script async src="//adverts.ukimediaevents.com/www/delivery/asyncjs.php"></script>')
}
else if (width >= 1601)  {
console.log ('wallpaperb');
document.write('<ins data-revive-zoneid="212" data-revive-ct0="%c" data-revive-id="7d3eab13b195263024792b3b73763e23"></ins><script async src="//adverts.ukimediaevents.com/www/delivery/asyncjs.php"></script>')
}
else {
console.log ('nowallpaper');
document.write('<div class=""></div>')
}
// -->
</SCRIPT>
</div>
</div>		
<div class="main-wrap">
<div class="top-bar">
<div class="wrap">
<div class="widget_text header-ad"><div class="textwidget custom-html-widget"><div class="header-ad">	
<div class="textwidget">
<SCRIPT LANGUAGE="javascript">
<!--
width = window.innerWidth;
console.log ('WIDTH' + width);
if (width > 480)  {
console.log ('hi');
document.write('<ins data-revive-zoneid="39" data-revive-ct0="%c" data-revive-id="7d3eab13b195263024792b3b73763e23"></ins><script async src="//adverts.ukimediaevents.com/www/delivery/asyncjs.php"></script>')
}
else {
console.log ('hi2SS');
document.write('<div class="mobile-header-ad">	<ins data-revive-zoneid="75" data-revive-id="7d3eab13b195263024792b3b73763e23"></ins><script async src="//adverts.ukimediaevents.com/www/delivery/asyncjs.php"></script> </div>')
}
// -->
</SCRIPT>
</div>
</div></div></div>
<section class="top-bar-content cf">
<div class="textwidget"><ul class="social-icons cf"><li><a href="https://twitter.com/PowertrainMag" class="icon fa fa-twitter" title="Twitter"><span class="visuallyhidden">Twitter</span></a></li><li><a href="https://www.linkedin.com/company/the-sustainable-internal-combustion-engine-symposium/?viewAsMember=true" class="icon fa fa-linkedin" title="linkedin"><span class="visuallyhidden">linkedin</span></a></li><li><a href="https://www.facebook.com/The-Sustainable-Internal-Combustion-Engine-Symposium-102571564565869/" class="icon fa fa-facebook" title="facebook"><span class="visuallyhidden">facebook</span></a></li><br />
</ul>
</div>
<div class="menu-top-bar-menu-container"><ul id="menu-top-bar-menu" class="menu"><li id="menu-item-3664" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3664"><a href="https://www.enginetechnologyinternational.com/email-news">Sign-up for Free Weekly E-Newsletter</a></li>
<li id="menu-item-3669" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3669"><a href="https://www.enginetechnologyinternational.com/contact-us">Contact Us</a></li>
<li id="menu-item-4508" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4508"><a href="https://www.enginetechnologyinternational.com/meet-the-team">Meet the Editors</a></li>
<li id="menu-item-9797" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9797"><a href="https://www.ukimediaevents.com/downloads/pdfs/enginemedia.pdf">Media Pack</a></li>
</ul></div>
</section>
</div>
</div>
<div id="main-head" class="main-head">
<div class="wrap">
<header class="default">
<div class="title">
<a href="https://www.enginetechnologyinternational.com/" title="Engine + Powertrain Technology International" rel="home">
<img src="https://www.enginetechnologyinternational.com/wp-content/uploads/2019/06/engine_powertrain.png" class="logo-image" alt="Engine + Powertrain Technology International" srcset="https://www.enginetechnologyinternational.com/wp-content/uploads/2019/06/engine_powertrain.png ,https://www.enginetechnologyinternational.com/wp-content/uploads/2019/06/engine_powertrain_ret.png 2x" />
</a>				</div>
<div class="right">
<div class="a-widget">
<!--/*
*
* Revive Adserver Asynchronous JS Tag
* - Generated with Revive Adserver v4.0.2
* - Doubleclick/DFP
*
*/-->
<ins data-revive-zoneid="40" data-revive-ct0="%c" data-revive-id="7d3eab13b195263024792b3b73763e23"></ins>
<script async src="//adverts.ukimediaevents.com/www/delivery/asyncjs.php"></script>			
</div>
</div>
</header>
</div>
<div class="main-nav">
<div class="navigation-wrap cf" data-sticky-nav="1" data-sticky-type="normal">
<nav class="navigation cf nav-full nav-dark has-search">
<div class="wrap">
<div class="mobile" data-type="off-canvas" data-search="1">
<a href="#" class="selected">
<span class="text">Navigate</span><span class="current"></span> <i class="hamburger fa fa-bars"></i>
</a>
</div>
<div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-2095" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-2095"><a title="Home" href="https://www.enginetechnologyinternational.com/"><i class="fa fa-home"></i></a></li>
<li id="menu-item-4464" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-cat-341 menu-item-4464"><a href="https://www.enginetechnologyinternational.com/news">News</a><ul class="mega-menu links row">
<li id="menu-item-4465" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-52 menu-item-4465"><a href="https://www.enginetechnologyinternational.com/news/appointments">Appointments</a></li>
<li id="menu-item-4466" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-53 menu-item-4466"><a href="https://www.enginetechnologyinternational.com/news/autonomous-vehicle-technologies">Autonomous Vehicle Technologies</a></li>
<li id="menu-item-4467" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-cat-41 menu-item-4467"><a href="https://www.enginetechnologyinternational.com/news/electric-powertrain-technologies">Electric Powertrain Technologies</a></li>
<li id="menu-item-4468" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-31 menu-item-4468"><a href="https://www.enginetechnologyinternational.com/news/emissions-control">Emissions</a></li>
<li id="menu-item-4469" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-32 menu-item-4469"><a href="https://www.enginetechnologyinternational.com/news/engine-components">Engine Components</a></li>
<li id="menu-item-4470" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-35 menu-item-4470"><a href="https://www.enginetechnologyinternational.com/news/engine-electronics">Engine Electronics</a></li>
<li id="menu-item-4471" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-50 menu-item-4471"><a href="https://www.enginetechnologyinternational.com/news/facility-development">Facility Developments</a></li>
<li id="menu-item-4472" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-45 menu-item-4472"><a href="https://www.enginetechnologyinternational.com/news/forced-induction">Forced Induction</a></li>
<li id="menu-item-4473" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-cat-44 menu-item-4473"><a href="https://www.enginetechnologyinternational.com/news/fuel-cells-technologies">Fuel Cell Technologies</a></li>
<li id="menu-item-4474" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-30 menu-item-4474"><a href="https://www.enginetechnologyinternational.com/news/fuels-lubricants">Fuels &#038; Lubricants</a></li>
<li id="menu-item-4475" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-46 menu-item-4475"><a href="https://www.enginetechnologyinternational.com/news/heavy-duty-diesel-engine-technologies">Heavy-duty &#038; Diesel Engine Technologies</a></li>
<li id="menu-item-4476" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-42 menu-item-4476"><a href="https://www.enginetechnologyinternational.com/news/hybrid-powertrain-technologies">Hybrid Powertrain Technologies</a></li>
<li id="menu-item-4477" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-37 menu-item-4477"><a href="https://www.enginetechnologyinternational.com/news/industry-forecasting">Industry Forecasting</a></li>
<li id="menu-item-4478" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-48 menu-item-4478"><a href="https://www.enginetechnologyinternational.com/news/legislation">Legislation</a></li>
<li id="menu-item-4479" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-33 menu-item-4479"><a href="https://www.enginetechnologyinternational.com/news/materials-surface-treatment">Materials &#038; Surface Treatment</a></li>
<li id="menu-item-4480" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-34 menu-item-4480"><a href="https://www.enginetechnologyinternational.com/news/metallurgy">Metallurgy</a></li>
<li id="menu-item-4481" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-43 menu-item-4481"><a href="https://www.enginetechnologyinternational.com/news/mild-hybrid-48v-technologies">Mild-hybrid &#038; 48V Technologies</a></li>
<li id="menu-item-4482" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-40 menu-item-4482"><a href="https://www.enginetechnologyinternational.com/news/new-engine">New Engine</a></li>
<li id="menu-item-4483" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-51 menu-item-4483"><a href="https://www.enginetechnologyinternational.com/news/partnerships-investments-acquisitions">Partnerships, Investments &#038; Acquisitions</a></li>
<li id="menu-item-4485" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-36 menu-item-4485"><a href="https://www.enginetechnologyinternational.com/news/quality-control">Quality Control</a></li>
<li id="menu-item-4484" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-38 menu-item-4484"><a href="https://www.enginetechnologyinternational.com/news/prototyping">Prototyping</a></li>
<li id="menu-item-4486" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-54 menu-item-4486"><a href="https://www.enginetechnologyinternational.com/news/conference-news">Sustainable ICE Symposium</a></li>
<li id="menu-item-4487" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-29 menu-item-4487"><a href="https://www.enginetechnologyinternational.com/news/testing">Testing</a></li>
<li id="menu-item-4488" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-49 menu-item-4488"><a href="https://www.enginetechnologyinternational.com/news/traction-control-systems">Traction Control Systems</a></li>
<li id="menu-item-4489" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-39 menu-item-4489"><a href="https://www.enginetechnologyinternational.com/news/transmissions-technologies">Transmissions Technologies</a></li>
</ul>
</li>
<li id="menu-item-4463" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-318 menu-item-4463"><a href="https://www.enginetechnologyinternational.com/features">Features</a></li>
<li id="menu-item-3623" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-cat-316 menu-item-3623"><a href="https://www.enginetechnologyinternational.com/online-magazines">Online Magazines</a>
<div class="mega-menu row">
<div class="col-3 sub-cats">
<ol class="sub-nav">
<li id="menu-item-10521" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-10521"><a href="https://www.enginetechnologyinternational.com/online-magazines/engine-technology/in-this-issue-june-2021.html">June 2021</a></li>
<li id="menu-item-10034" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-10034"><a href="https://www.enginetechnologyinternational.com/online-magazines/engine-technology/in-this-issue-march-2021.html">March 2021</a></li>
<li id="menu-item-9459" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-9459"><a href="https://www.enginetechnologyinternational.com/online-magazines/engine-technology/in-this-issue-january-2021.html">January 2021</a></li>
<li id="menu-item-9314" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-9314"><a href="https://www.enginetechnologyinternational.com/online-magazines/engine-technology/in-this-issue-september-2020-2.html">September 2020</a></li>
<li id="menu-item-9285" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-9285"><a href="https://www.enginetechnologyinternational.com/online-magazines/transmission-technology/in-this-issue-september-2020.html">Transmission Technology International 2020</a></li>
<li id="menu-item-6447" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-572 menu-item-6447"><a href="https://www.enginetechnologyinternational.com/online-magazines/engine-technology">Engine + Powertrain Technology International</a></li>
<li id="menu-item-9286" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-573 menu-item-9286"><a href="https://www.enginetechnologyinternational.com/online-magazines/transmission-technology">Transmission Technology International</a></li>
<li id="menu-item-4426" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4426"><a href="https://ukimediaevents.com/recard/eticard.html">Subscribe to Engine + Powertrain Technology International</a></li>
<li id="menu-item-6448" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6448"><a href="https://www.ukimediaevents.com/recards/forms/1775">Subscribe to Transmission Technology</a></li>
</ol>
</div>
<div class="col-9 extend">
<section class="col-6 featured">
<span class="heading">Read The Latest Issue</span>
<div class="highlights">
<article>
<a href="https://www.enginetechnologyinternational.com/online-magazines/engine-technology/in-this-issue-june-2021.html" title="In this Issue &#8211; June 2021" class="image-link">
<a href="https://www.ukimediaevents.com/publication/c840c039/1" target="_blank" ><img width="351" height="185" src="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/06/etm-wp-cover-351x185.jpg" class="image wp-post-image" alt="" title="In this Issue &#8211; June 2021" data-attachment-id="10514" data-permalink="https://www.enginetechnologyinternational.com/online-magazines/engine-technology/in-this-issue-june-2021.html/attachment/etm-wp-cover-5" data-orig-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/06/etm-wp-cover.jpg" data-orig-size="700,335" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="etm-wp-cover" data-image-description="" data-medium-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/06/etm-wp-cover-300x144.jpg" data-large-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/06/etm-wp-cover.jpg" /></a>				</a>
<div class="cf listing-meta meta above">
<time datetime="2021-06-04T13:57:02+01:00" class="meta-item">4th June 2021</time>					
</div>
<h2 class="post-title">
<a href="https://www.enginetechnologyinternational.com/online-magazines/engine-technology/in-this-issue-june-2021.html" title="In this Issue &#8211; June 2021">In this Issue &#8211; June 2021</a>
</h2>
</article>
</div>
</section>
<section class="col-6 recent-posts">
<span class="heading">Recent Magazine Issues</span>
<div class="posts-list">
<div class="post">
<a href="https://www.enginetechnologyinternational.com/online-magazines/engine-technology/in-this-issue-june-2021.html"><a href="https://www.ukimediaevents.com/publication/c840c039/1" target="_blank" ><img width="110" height="96" src="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/06/etm-wp-cover-110x96.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" title="In this Issue &#8211; June 2021" data-attachment-id="10514" data-permalink="https://www.enginetechnologyinternational.com/online-magazines/engine-technology/in-this-issue-june-2021.html/attachment/etm-wp-cover-5" data-orig-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/06/etm-wp-cover.jpg" data-orig-size="700,335" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="etm-wp-cover" data-image-description="" data-medium-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/06/etm-wp-cover-300x144.jpg" data-large-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/06/etm-wp-cover.jpg" /></a>
</a>
<div class="content">
<div class="cf listing-meta meta above">
<time datetime="2021-06-04T13:57:02+01:00" class="meta-item">4th June 2021</time>					
</div>
<a href="https://www.enginetechnologyinternational.com/online-magazines/engine-technology/in-this-issue-june-2021.html">In this Issue &#8211; June 2021</a>
</div>
</div>
<div class="post">
<a href="https://www.enginetechnologyinternational.com/online-magazines/engine-technology/in-this-issue-march-2021.html"><a href="https://www.ukimediaevents.com/publication/c141a6ab/1" target="_blank" ><img width="110" height="96" src="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/03/etm-wp-cover-110x96.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" title="In this Issue &#8211; March 2021" data-attachment-id="10030" data-permalink="https://www.enginetechnologyinternational.com/online-magazines/engine-technology/in-this-issue-march-2021.html/attachment/etm-wp-cover-4" data-orig-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/03/etm-wp-cover.jpg" data-orig-size="700,335" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="etm-wp-cover" data-image-description="" data-medium-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/03/etm-wp-cover-300x144.jpg" data-large-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/03/etm-wp-cover.jpg" /></a>
</a>
<div class="content">
<div class="cf listing-meta meta above">
<time datetime="2021-03-12T14:15:38+01:00" class="meta-item">12th March 2021</time>					
</div>
<a href="https://www.enginetechnologyinternational.com/online-magazines/engine-technology/in-this-issue-march-2021.html">In this Issue &#8211; March 2021</a>
</div>
</div>
<div class="post">
<a href="https://www.enginetechnologyinternational.com/online-magazines/engine-technology/in-this-issue-january-2021.html"><a href="https://www.ukimediaevents.com/publication/9105e03c/1" target="_blank" ><img width="110" height="96" src="https://www.enginetechnologyinternational.com/wp-content/uploads/2020/11/etm-wp-cover-110x96.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" title="In this Issue &#8211; January 2021" data-attachment-id="9457" data-permalink="https://www.enginetechnologyinternational.com/online-magazines/engine-technology/in-this-issue-january-2021.html/attachment/etm-wp-cover-3" data-orig-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2020/11/etm-wp-cover.jpg" data-orig-size="700,335" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="etm-wp-cover" data-image-description="" data-medium-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2020/11/etm-wp-cover-300x144.jpg" data-large-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2020/11/etm-wp-cover.jpg" /></a>
</a>
<div class="content">
<div class="cf listing-meta meta above">
<time datetime="2020-11-19T14:19:51+01:00" class="meta-item">19th November 2020</time>					
</div>
<a href="https://www.enginetechnologyinternational.com/online-magazines/engine-technology/in-this-issue-january-2021.html">In this Issue &#8211; January 2021</a>
</div>
</div>
</div>
</section>
</div>
</div>
</li>
<li id="menu-item-3625" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-317 menu-item-3625"><a href="https://www.enginetechnologyinternational.com/opinion">Opinion</a></li>
<li id="menu-item-10109" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-575 menu-item-10109"><a href="https://www.enginetechnologyinternational.com/webinars">Webinars</a></li>
<li id="menu-item-3626" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-319 menu-item-3626"><a href="https://www.enginetechnologyinternational.com/videos">Videos</a></li>
<li id="menu-item-3624" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3624"><a href="https://ukimediaevents.com/recard/eticard.html">Subscribe</a></li>
<li id="menu-item-3621" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3621"><a href="https://www.enginetechnologyinternational.com/supplier-spotlight">Supplier Spotlight</a></li>
<li id="menu-item-3645" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3645"><a href="http://www.ukimediaevents.com/engineoftheyear/">Awards</a></li>
<li id="menu-item-3642" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-3642"><a href="https://www.enginetechnologyinternational.com/jobs">Jobs</a>
<ul class="sub-menu">
<li id="menu-item-3644" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3644"><a href="https://www.enginetechnologyinternational.com/jobs">Browse Jobs</a></li>
<li id="menu-item-3643" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3643"><a href="https://www.enginetechnologyinternational.com/jobs/post-job-free">Post a Job &#8211; It&#8217;s FREE!</a></li>
<li id="menu-item-6702" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6702"><a href="https://www.enginetechnologyinternational.com/jobs/jobs-dashboard">Manage Jobs (Employers)</a></li>
</ul>
</li>
</ul></div>				
</div>
</nav>
<div class="nav-search -search wrap">
<div class="search-overlay">
<a href="#" title="Search" class="search-icon"><i class="fa fa-search"></i></a>
<div class="search">
<form role="search" action="https://www.enginetechnologyinternational.com/" method="get">
<input type="text" name="s" class="query live-search-query" value="" placeholder="Search..."/>
<button class="search-button" type="submit"><i class="fa fa-search"></i></button>
</form>
</div> <!-- .search -->			</div>
</div>
</div>
</div>		
</div>
<div class="breadcrumbs-wrap">
<div class="wrap">
<div class="breadcrumbs"><span class="location">You are at:</span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="https://www.enginetechnologyinternational.com/"><span itemprop="title">Home</span></a></span><span class="delim">&raquo;</span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url"  href="https://www.enginetechnologyinternational.com/news"><span itemprop="title">News</span></a></span><span class="delim">&raquo;</span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url"  href="https://www.enginetechnologyinternational.com/news/electric-powertrain-technologies"><span itemprop="title">Electric Powertrain Technologies</span></a></span><span class="delim">&raquo;</span><span class="current">StoreDot announces patent for system to reduce EV charge times</span></div>		</div>
</div>
<div class="main wrap cf">
<div class="row">
<div class="col-8 main-content">
<article id="post-10990" class="post-10990 post type-post status-publish format-standard has-post-thumbnail category-electric-powertrain-technologies category-fuel-cells-technologies">
<header class="post-header-b cf">
<div class="category cf">
<span class="cat-title cat-41"><a href="https://www.enginetechnologyinternational.com/news/electric-powertrain-technologies" title="Electric Powertrain Technologies">Electric Powertrain Technologies</a></span>
</div>
<div class="heading cf">
<h1 class="post-title">
StoreDot announces patent for system to reduce EV charge times			</h1>
</div>
<div class="post-meta-b cf">
<span class="author-img"><img alt='mm' src='https://www.enginetechnologyinternational.com/wp-content/uploads/2021/01/Website-Pic-square-150x150.jpg' class='avatar avatar-35 photo' height='35' width='35' /></span>
<span class="posted-by">By 
<a href="https://www.enginetechnologyinternational.com/author/callumbrookjones" title="Posts by Callum Brook-Jones" rel="author">Callum Brook-Jones</a>			</span>
<span class="posted-on">
<time class="post-date" datetime="2021-08-25T12:33:26+01:00">25th August 2021</time>
</span>
<a href="https://www.enginetechnologyinternational.com/news/fuel-cells-technologies/storedot-announces-patent-for-system-to-reduce-ev-charge-times.html#respond" class="comments"><i class="fa fa-comments-o"></i>No Comments</a>
</div>	
<div class="post-share-b cf">
<a href="http://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fwww.enginetechnologyinternational.com%2Fnews%2Ffuel-cells-technologies%2Fstoredot-announces-patent-for-system-to-reduce-ev-charge-times.html" class="cf service linkedin" target="_blank">
<i class="fa fa-linkedin"></i>
<span class="label">LinkedIn</span>
</a>
<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.enginetechnologyinternational.com%2Fnews%2Ffuel-cells-technologies%2Fstoredot-announces-patent-for-system-to-reduce-ev-charge-times.html&#038;text=StoreDot%20announces%20patent%20for%20system%20to%20reduce%20EV%20charge%20times" class="cf service twitter" target="_blank">
<i class="fa fa-twitter"></i>
<span class="label">Tweet</span>
</a>
<a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.enginetechnologyinternational.com%2Fnews%2Ffuel-cells-technologies%2Fstoredot-announces-patent-for-system-to-reduce-ev-charge-times.html" class="cf service facebook" target="_blank">
<i class="fa fa-facebook"></i>
<span class="label">Share</span>
</a>
<a href="mailto:?subject=StoreDot%20announces%20patent%20for%20system%20to%20reduce%20EV%20charge%20times&#038;body=https%3A%2F%2Fwww.enginetechnologyinternational.com%2Fnews%2Ffuel-cells-technologies%2Fstoredot-announces-patent-for-system-to-reduce-ev-charge-times.html" class="cf service email" target="_blank">
<i class="fa fa-envelope-o"></i>
<span class="label">Email</span>
</a>
<a href="#" class="show-more">+</a>
</div>
<div class="featured">
<a href="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/ETM-Web-August-25-StoreDot.jpg" title="StoreDot announces patent for system to reduce EV charge times">
<img width="700" height="335" src="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/ETM-Web-August-25-StoreDot.jpg" class="attachment-main-featured size-main-featured wp-post-image" alt="" title="StoreDot announces patent for system to reduce EV charge times" srcset="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/ETM-Web-August-25-StoreDot.jpg 700w, https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/ETM-Web-August-25-StoreDot-300x144.jpg 300w, https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/ETM-Web-August-25-StoreDot-200x96.jpg 200w, https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/ETM-Web-August-25-StoreDot-600x287.jpg 600w" sizes="(max-width: 700px) 100vw, 700px" data-attachment-id="10991" data-permalink="https://www.enginetechnologyinternational.com/news/fuel-cells-technologies/storedot-announces-patent-for-system-to-reduce-ev-charge-times.html/attachment/etm-web-august-25-storedot" data-orig-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/ETM-Web-August-25-StoreDot.jpg" data-orig-size="700,335" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ETM Web August 25 StoreDot" data-image-description="" data-medium-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/ETM-Web-August-25-StoreDot-300x144.jpg" data-large-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/ETM-Web-August-25-StoreDot.jpg" />				
</a>
</div>		
</header><!-- .post-header -->
<div class="post-content post-dynamic">
<p>StoreDot, a producer of extreme fast charging (XFC) battery technology for EVs, has announced a system that it claims will significantly reduce EV charging times.</p>
<p>The company says the technology will be made available to the entire market, to help expand existing charging infrastructures and speed up the world’s adoption of EVs.</p><div class='code-block code-block-2' style='margin: 8px 0; clear: both;'>
<SCRIPT LANGUAGE="javascript">
<!--
width = window.innerWidth;
console.log ('WIDTH' + width);
if (width >= 376 && width <=424)  {
console.log ('smallscreen');
document.write('<ins data-revive-zoneid="38" data-revive-ct0="%c" data-revive-id="7d3eab13b195263024792b3b73763e23"></ins><script async src="//adverts.ukimediaevents.com/www/delivery/asyncjs.php"></script>')
}
else {
console.log ('nompuad');
document.write('<div class=""></div>')
}
// -->
</SCRIPT>
</div>
<div class='code-block code-block-1' style='margin: 8px 0 8px 8px; float: right;'>
<SCRIPT LANGUAGE="javascript">
<!--
width = window.innerWidth;
console.log ('WIDTH' + width);
if (width <= 375)  {
console.log ('smallscreen');
document.write('<ins data-revive-zoneid="38" data-revive-ct0="%c" data-revive-id="7d3eab13b195263024792b3b73763e23"></ins><script async src="//adverts.ukimediaevents.com/www/delivery/asyncjs.php"></script>')
}
else if (width >= 425)  {
console.log ('largescreen');
document.write('<ins data-revive-zoneid="38" data-revive-ct0="%c" data-revive-id="7d3eab13b195263024792b3b73763e23"></ins><script async src="//adverts.ukimediaevents.com/www/delivery/asyncjs.php"></script>')
}
else {
console.log ('nompuad');
document.write('<div class=""></div>')
}
// -->
</SCRIPT>
</div>
<p>The latest system will utilize hardware and software advances to create a booster feature, enabling the battery, or batteries, to analyze charging station capability in real time and consequently adjust the battery’s ability to carry high current rates.</p>
<p>“This is an important step for the EV global community as it will allow all of us to charge faster with very minimal changes to the current infrastructure and future deployment process,” commented Doron Myersdorf, CEO of StoreDot.<strong> </strong>“That is why we believe it’s critical to offer this world-leading innovation to other organizations on an open-source basis.”</p>
<p>The company claims the system will allow cells to accept a higher current without the chance of overheating. The system will also be able to be retrofitted to boost existing infrastructure, allowing for faster charge times to be achieved without needing to upgrade equipment.</p>
<p>Myersdorf continued, “The global uptake and appeal of electric vehicles is crucial if we want to live in a cleaner, zero-emissions world. By sharing this novel approach, StoreDot aims to play a pivotal role in helping to achieve this objective. We want to work with and support the global community, including automotive manufacturers and infrastructure providers, in their missions as well, especially when the industry is facing a number of charging infrastructure deployment challenges, not least the global semiconductor shortage.”</p>
<!-- AI CONTENT END 4 -->
</div><!-- .post-content -->
<div class="post-share">
<span class="text">Share this story:</span>
<span class="share-links">
<a href="http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fwww.enginetechnologyinternational.com%2Fnews%2Ffuel-cells-technologies%2Fstoredot-announces-patent-for-system-to-reduce-ev-charge-times.html" class="fa fa-linkedin" title="Share on LinkedIn" target="_blank">
<span class="visuallyhidden">LinkedIn</span></a>
<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.enginetechnologyinternational.com%2Fnews%2Ffuel-cells-technologies%2Fstoredot-announces-patent-for-system-to-reduce-ev-charge-times.html&text=StoreDot%20announces%20patent%20for%20system%20to%20reduce%20EV%20charge%20times" 
class="fa fa-twitter" title="Tweet It" target="_blank">
<span class="visuallyhidden">Twitter</span></a>
<a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.enginetechnologyinternational.com%2Fnews%2Ffuel-cells-technologies%2Fstoredot-announces-patent-for-system-to-reduce-ev-charge-times.html" class="fa fa-facebook" title="Share on Facebook" target="_blank">
<span class="visuallyhidden">Facebook</span></a>
<a href="mailto:?subject=StoreDot%20announces%20patent%20for%20system%20to%20reduce%20EV%20charge%20times&amp;body=https%3A%2F%2Fwww.enginetechnologyinternational.com%2Fnews%2Ffuel-cells-technologies%2Fstoredot-announces-patent-for-system-to-reduce-ev-charge-times.html" class="fa fa-envelope-o"
title="Share via Email">
<span class="visuallyhidden">Email</span></a>
</span>
</div>		
</article>
<div class="author-box">
<h3 class="section-head">About Author</h3>
<section class="author-info">
<div class="auth-avatar">
<img alt='mm' src='https://www.enginetechnologyinternational.com/wp-content/uploads/2021/01/Website-Pic-square-150x150.jpg' class='avatar avatar-150 photo' height='150' width='150' /></div>
<div class="description">
<a href="https://www.enginetechnologyinternational.com/author/callumbrookjones" title="Posts by Callum Brook-Jones" rel="author">Callum Brook-Jones</a>
<ul class="social-icons">
</ul>
<p class="bio">After spending the past six years working as a mechanic for various motorsport and high-end performance car companies, Callum recently joined UKi Media &amp; Events as an assistant editor. In this role he will use his vast practical knowledge and passion for automotive to produce informative news pieces for multiple vehicle-related sectors.</p>
</div>
</section>	</div>
<section class="related-posts">
<h3 class="section-head"><span class="color">Related</span> Posts</h3> 
<ul class="highlights-box three-col related-posts">
<li class="highlights column one-third">
<article>
<a href="https://www.enginetechnologyinternational.com/news/fuel-cells-technologies/arcola-energy-to-conduct-hydrogen-road-freight-testing.html" title="Arcola Energy to conduct hydrogen road freight testing" class="image-link">
<img width="214" height="140" src="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/TEM-and-ETM-Web-August-23-Arcola-1-e1629725218361-214x140.jpeg" class="image wp-post-image" alt="" title="Arcola Energy to conduct hydrogen road freight testing" data-attachment-id="10982" data-permalink="https://www.enginetechnologyinternational.com/news/fuel-cells-technologies/arcola-energy-to-conduct-hydrogen-road-freight-testing.html/attachment/tem-and-etm-web-august-23-arcola-1" data-orig-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/TEM-and-ETM-Web-August-23-Arcola-1-e1629725218361.jpeg" data-orig-size="800,382" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="TEM and ETM Web August 23 Arcola 1" data-image-description="" data-medium-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/TEM-and-ETM-Web-August-23-Arcola-1-e1629725218361-300x143.jpeg" data-large-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/TEM-and-ETM-Web-August-23-Arcola-1-e1629725218361.jpeg" />	
</a>
<div class="cf listing-meta meta above">
<time datetime="2021-08-23T14:34:19+01:00" class="meta-item">23rd August 2021</time>					
</div>
<h2><a href="https://www.enginetechnologyinternational.com/news/fuel-cells-technologies/arcola-energy-to-conduct-hydrogen-road-freight-testing.html" title="Arcola Energy to conduct hydrogen road freight testing">Arcola Energy to conduct hydrogen road freight testing</a></h2>
</article>
</li>
<li class="highlights column one-third">
<article>
<a href="https://www.enginetechnologyinternational.com/news/partnerships-investments-acquisitions/nexus-fc-to-receive-us1-6m-in-public-funding.html" title="Nexus-fc to receive US$1.6m in public funding" class="image-link">
<img width="214" height="140" src="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/20-08-SP-e1629457060256-214x140.png" class="image wp-post-image" alt="" title="Nexus-fc to receive US$1.6m in public funding" data-attachment-id="10965" data-permalink="https://www.enginetechnologyinternational.com/news/partnerships-investments-acquisitions/nexus-fc-to-receive-us1-6m-in-public-funding.html/attachment/20-08-sp" data-orig-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/20-08-SP-e1629457060256.png" data-orig-size="895,427" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="20-08 SP" data-image-description="" data-medium-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/20-08-SP-e1629457060256-300x143.png" data-large-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/20-08-SP-e1629457060256.png" />	
</a>
<div class="cf listing-meta meta above">
<time datetime="2021-08-20T12:00:03+01:00" class="meta-item">20th August 2021</time>					
</div>
<h2><a href="https://www.enginetechnologyinternational.com/news/partnerships-investments-acquisitions/nexus-fc-to-receive-us1-6m-in-public-funding.html" title="Nexus-fc to receive US$1.6m in public funding">Nexus-fc to receive US$1.6m in public funding</a></h2>
</article>
</li>
<li class="highlights column one-third">
<article>
<a href="https://www.enginetechnologyinternational.com/news/partnerships-investments-acquisitions/borgwarner-invests-in-cellink.html" title="BorgWarner invests in CelLink" class="image-link">
<img width="214" height="140" src="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/ETM-Web-August-17-BorgWarnerCellink-214x140.jpg" class="image wp-post-image" alt="" title="BorgWarner invests in CelLink" data-attachment-id="10945" data-permalink="https://www.enginetechnologyinternational.com/news/partnerships-investments-acquisitions/borgwarner-invests-in-cellink.html/attachment/etm-web-august-17-borgwarnercellink" data-orig-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/ETM-Web-August-17-BorgWarnerCellink.jpg" data-orig-size="700,335" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ETM Web August 17 BorgWarnerCellink" data-image-description="" data-medium-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/ETM-Web-August-17-BorgWarnerCellink-300x144.jpg" data-large-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/ETM-Web-August-17-BorgWarnerCellink.jpg" />	
</a>
<div class="cf listing-meta meta above">
<time datetime="2021-08-17T13:10:53+01:00" class="meta-item">17th August 2021</time>					
</div>
<h2><a href="https://www.enginetechnologyinternational.com/news/partnerships-investments-acquisitions/borgwarner-invests-in-cellink.html" title="BorgWarner invests in CelLink">BorgWarner invests in CelLink</a></h2>
</article>
</li>
</ul>
</section>
<div class="comments">
<div id="comments">
<p class="nocomments">Comments are closed.</p>
</div><!-- #comments -->
</div>
</div>
<aside class="col-4 sidebar" data-sticky="1">
<div class="theiaStickySidebar">
<ul>
<li id="bunyad_ads_widget-8" class="widget code-widget">		
<div class="a-widget">
<!--/*
*
* Revive Adserver Asynchronous JS Tag
* - Generated with Revive Adserver v4.0.2
* - Doubleclick/DFP
*
*/-->
<ins data-revive-zoneid="36" data-revive-ct0="%c" data-revive-id="7d3eab13b195263024792b3b73763e23"></ins>
<script async src="//adverts.ukimediaevents.com/www/delivery/asyncjs.php"></script>			
</div>
</li>
<li id="bunyad_ads_widget-9" class="widget code-widget">		
<div class="a-widget">
<!--/*
*
* Revive Adserver Asynchronous JS Tag
* - Generated with Revive Adserver v4.0.2
* - Doubleclick/DFP
*
*/-->
<ins data-revive-zoneid="37" data-revive-ct0="%c" data-revive-id="7d3eab13b195263024792b3b73763e23"></ins>
<script async src="//adverts.ukimediaevents.com/www/delivery/asyncjs.php"></script>			
</div>
</li>
<li id="bunyad-popular-posts-widget-3" class="widget popular-posts">			<h3 class="widgettitle">Most Read</h3>			
<ul class="posts-list">
<li>
<a href="https://www.enginetechnologyinternational.com/news/emissions-control/fev-develops-emission-reduction-solutions-for-heavy-duty-vehicles.html"><img width="110" height="96" src="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/FEV-Group-trucks-web-pic-e1629391465904-1078x516-110x96.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" title="FEV develops emission-reduction solutions for heavy-duty vehicles" data-attachment-id="10967" data-permalink="https://www.enginetechnologyinternational.com/news/emissions-control/fev-develops-emission-reduction-solutions-for-heavy-duty-vehicles.html/attachment/fev-group-trucks-web-pic-e1629391465904-1078x516" data-orig-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/FEV-Group-trucks-web-pic-e1629391465904-1078x516.jpg" data-orig-size="1078,516" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="FEV-Group-trucks-web-pic&#8211;e1629391465904-1078&#215;516" data-image-description="" data-medium-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/FEV-Group-trucks-web-pic-e1629391465904-1078x516-300x144.jpg" data-large-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/FEV-Group-trucks-web-pic-e1629391465904-1078x516-1024x490.jpg" />					
</a>
<div class="content">
<div class="cf listing-meta meta above">
<time datetime="2021-08-20T10:32:37+01:00" class="meta-item">20th August 2021</time>					
</div>
<a href="https://www.enginetechnologyinternational.com/news/emissions-control/fev-develops-emission-reduction-solutions-for-heavy-duty-vehicles.html" title="FEV develops emission-reduction solutions for heavy-duty vehicles">
FEV develops emission-reduction solutions for heavy-duty vehicles</a>
</div>
</li>
<li>
<a href="https://www.enginetechnologyinternational.com/news/porsche-unveils-additive-manufactured-electric-drive-housing.html"><img width="110" height="96" src="https://www.enginetechnologyinternational.com/wp-content/uploads/2020/12/b-S20_5725-110x96.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" title="Porsche unveils additive manufactured electric drive housing" data-attachment-id="9627" data-permalink="https://www.enginetechnologyinternational.com/news/porsche-unveils-additive-manufactured-electric-drive-housing.html/attachment/b-s20_5725" data-orig-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2020/12/b-S20_5725.jpg" data-orig-size="1000,563" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="b-S20_5725" data-image-description="" data-medium-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2020/12/b-S20_5725-300x169.jpg" data-large-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2020/12/b-S20_5725.jpg" />					
</a>
<div class="content">
<div class="cf listing-meta meta above">
<time datetime="2020-12-17T16:12:15+01:00" class="meta-item">17th December 2020</time>					
</div>
<a href="https://www.enginetechnologyinternational.com/news/porsche-unveils-additive-manufactured-electric-drive-housing.html" title="Porsche unveils additive manufactured electric drive housing">
Porsche unveils additive manufactured electric drive housing</a>
</div>
</li>
<li>
<a href="https://www.enginetechnologyinternational.com/news/materials-surface-treatment/zircotec-first-thermal-coating.html"><img width="110" height="96" src="https://www.enginetechnologyinternational.com/wp-content/uploads/2018/03/Zircotec-110x96.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="First thermal barrier coating developed by Zircotec" title="First thermal barrier coating developed by Zircotec" data-attachment-id="4554" data-permalink="https://www.enginetechnologyinternational.com/news/materials-surface-treatment/zircotec-first-thermal-coating.html/attachment/zircotec" data-orig-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2018/03/Zircotec.jpg" data-orig-size="700,335" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="First thermal barrier coating developed by Zircotec" data-image-description="" data-medium-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2018/03/Zircotec-300x144.jpg" data-large-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2018/03/Zircotec.jpg" />					
</a>
<div class="content">
<div class="cf listing-meta meta above">
<time datetime="2018-03-12T14:36:41+01:00" class="meta-item">12th March 2018</time>					
</div>
<a href="https://www.enginetechnologyinternational.com/news/materials-surface-treatment/zircotec-first-thermal-coating.html" title="First thermal barrier coating developed by Zircotec">
First thermal barrier coating developed by Zircotec</a>
</div>
</li>
</ul>
</li>
<li id="custom_html-3" class="widget_text widget widget_custom_html"><h3 class="widgettitle">FREE WEEKLY E-NEWSLETTER</h3><div class="textwidget custom-html-widget"><div class="container"><center>
<h4>Receive breaking stories and features in your inbox each week, for free</h4><br/>
Enter your email address:<br/><form action="/email-news/" method="get">
<input name="email" type="email" required>
<br><br>
<div style="text-align: center">
<input type="submit" value="Continue >>">
</div>
</form></center>
</div></div></li>
<li id="wpbdp_randomlistingswidget-2" class="widget widget_wpbdp_randomlistingswidget"><h3 class="widgettitle">Supplier Spotlight</h3><ul class="wpbdp-listings-widget-list"><li><a href="https://www.enginetechnologyinternational.com/supplier-spotlight/voss-automotive-inc/"><img width="180" height="45" src="https://www.enginetechnologyinternational.com/wp-content/uploads/2018/02/982-200x50.jpg" class="listing-image" alt="" srcset="https://www.enginetechnologyinternational.com/wp-content/uploads/2018/02/982-200x50.jpg 200w, https://www.enginetechnologyinternational.com/wp-content/uploads/2018/02/982.jpg 230w" sizes="(max-width: 180px) 100vw, 180px" data-attachment-id="3938" data-permalink="https://www.enginetechnologyinternational.com/supplier-spotlight/voss-automotive-inc/attachment/982" data-orig-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2018/02/982.jpg" data-orig-size="230,57" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="982" data-image-description="" data-medium-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2018/02/982.jpg" data-large-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2018/02/982.jpg" /></a></li><li><a href="https://www.enginetechnologyinternational.com/supplier-spotlight/econamiq/"><img width="180" height="35" src="https://www.enginetechnologyinternational.com/wp-content/uploads/2020/07/ECONAMIQ-logo-hires-200x39.jpg" class="listing-image" alt="" srcset="https://www.enginetechnologyinternational.com/wp-content/uploads/2020/07/ECONAMIQ-logo-hires-200x39.jpg 200w, https://www.enginetechnologyinternational.com/wp-content/uploads/2020/07/ECONAMIQ-logo-hires-300x59.jpg 300w, https://www.enginetechnologyinternational.com/wp-content/uploads/2020/07/ECONAMIQ-logo-hires-768x150.jpg 768w, https://www.enginetechnologyinternational.com/wp-content/uploads/2020/07/ECONAMIQ-logo-hires-1024x201.jpg 1024w, https://www.enginetechnologyinternational.com/wp-content/uploads/2020/07/ECONAMIQ-logo-hires-600x118.jpg 600w" sizes="(max-width: 180px) 100vw, 180px" data-attachment-id="8947" data-permalink="https://www.enginetechnologyinternational.com/supplier-spotlight/econamiq/attachment/econamiq-logo-hires" data-orig-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2020/07/ECONAMIQ-logo-hires.jpg" data-orig-size="1669,327" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="ECONAMIQ logo hires" data-image-description="" data-medium-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2020/07/ECONAMIQ-logo-hires-300x59.jpg" data-large-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2020/07/ECONAMIQ-logo-hires-1024x201.jpg" /></a></li><li><a href="https://www.enginetechnologyinternational.com/supplier-spotlight/borgwarner/"><img width="180" height="57" src="https://www.enginetechnologyinternational.com/wp-content/uploads/2020/07/borg-logo-200x63.png" class="listing-image" alt="" srcset="https://www.enginetechnologyinternational.com/wp-content/uploads/2020/07/borg-logo-200x63.png 200w, https://www.enginetechnologyinternational.com/wp-content/uploads/2020/07/borg-logo-300x95.png 300w, https://www.enginetechnologyinternational.com/wp-content/uploads/2020/07/borg-logo-600x190.png 600w, https://www.enginetechnologyinternational.com/wp-content/uploads/2020/07/borg-logo.png 631w" sizes="(max-width: 180px) 100vw, 180px" data-attachment-id="8966" data-permalink="https://www.enginetechnologyinternational.com/supplier-spotlight/borgwarner/attachment/borg-logo" data-orig-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2020/07/borg-logo.png" data-orig-size="631,200" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="borg logo" data-image-description="" data-medium-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2020/07/borg-logo-300x95.png" data-large-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2020/07/borg-logo.png" /></a></li><li><a href="https://www.enginetechnologyinternational.com/supplier-spotlight/valvoline/"><img width="180" height="127" src="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/US_Valvoline_Logo_positive_CMYK-200x141.png" class="listing-image" alt="" srcset="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/US_Valvoline_Logo_positive_CMYK-200x141.png 200w, https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/US_Valvoline_Logo_positive_CMYK-300x211.png 300w, https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/US_Valvoline_Logo_positive_CMYK-768x540.png 768w, https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/US_Valvoline_Logo_positive_CMYK-269x192.png 269w, https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/US_Valvoline_Logo_positive_CMYK-569x400.png 569w, https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/US_Valvoline_Logo_positive_CMYK.png 961w" sizes="(max-width: 180px) 100vw, 180px" data-attachment-id="10885" data-permalink="https://www.enginetechnologyinternational.com/supplier-spotlight/valvoline/attachment/us_valvoline_logo_positive_cmyk" data-orig-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/US_Valvoline_Logo_positive_CMYK.png" data-orig-size="961,676" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="US_Valvoline_Logo_positive_CMYK" data-image-description="" data-medium-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/US_Valvoline_Logo_positive_CMYK-300x211.png" data-large-file="https://www.enginetechnologyinternational.com/wp-content/uploads/2021/08/US_Valvoline_Logo_positive_CMYK.png" /></a></li></ul></li>
</ul>
</div>
</aside>
</div> <!-- .row -->
</div> <!-- .main -->
		
<footer class="main-footer">
<div class="wrap">
</div>
<div class="lower-foot">
<div class="wrap">
<div class="widgets">
<div class="textwidget"><p>© 2021 UKi Media &amp; Events a division of UKIP Media &amp; Events Ltd</p>
</div>
<div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-2080" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2080"><a rel="nofollow" href="http://www.ukimediaevents.com/policies.php#cookie">Cookie Policy</a></li>
<li id="menu-item-2078" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2078"><a rel="nofollow" href="http://www.ukimediaevents.com/policies.php#privacy">Privacy Policy</a></li>
<li id="menu-item-2160" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2160"><a rel="nofollow" href="http://www.ukimediaevents.com/policies.php#terms">Terms &#038; Conditions</a></li>
<li id="menu-item-2161" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2161"><a rel="nofollow" href="http://www.ukimediaevents.com/takedown.php">Notice &#038; Takedown Policy</a></li>
<li id="menu-item-2162" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2162"><a rel="nofollow" href="http://www.ukimediaevents.com/policies.php#faqs">Site FAQs</a></li>
</ul></div><div class="menu-uki-network-menu-container"><ul id="menu-uki-network-menu" class="menu"><li id="menu-item-7725" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7725"><a href="https://www.automotiveinteriorsworld.com">Automotive Interiors</a></li>
<li id="menu-item-4939" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4939"><a href="https://www.automotivetestingtechnologyinternational.com">Automotive Testing</a></li>
<li id="menu-item-5869" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5869"><a href="https://www.autonomousvehicleinternational.com">Autonomous Vehicle</a></li>
<li id="menu-item-4942" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4942"><a href="https://www.pmw-magazine.com">Professional Motorsport</a></li>
<li id="menu-item-5187" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5187"><a href="https://www.tiretechnologyinternational.com">Tire Technology</a></li>
</ul></div>			</div>
</div>
</div>		
</footer>
</div> <!-- .main-wrap -->
<script type="text/javascript">var linkToLBMPolicyPage = "http://www.ukimediaevents.com/policies.php#cookie"; var ppBgColor = '#22A7D4'; var ppFontColor = '#ffffff';var ppOpacity = '1.0'</script>
<script type="text/javascript" src="https://www.enginetechnologyinternational.com/wp-content/themes/smartmag/js/cookiepolicy.js"></script>
<script type="text/javascript">
jQuery(document).ready(function(){
var wpfcWpfcAjaxCall = function(polls){
if(polls.length > 0){
poll_id = polls.last().attr('id').match(/\d+/)[0];
jQuery.ajax({
type: 'POST', 
url: pollsL10n.ajax_url,
dataType : "json",
data : {"action": "wpfc_wppolls_ajax_request", "poll_id": poll_id, "nonce" : "b4a81f2f66"},
cache: false, 
success: function(data){
if(data === true){
poll_result(poll_id);
}else if(data === false){
poll_booth(poll_id);
}
polls.length = polls.length - 1;
setTimeout(function(){
wpfcWpfcAjaxCall(polls);
}, 1000);
}
});
}
};
var polls = jQuery('div[id^=\"polls-\"][id$=\"-loading\"]');
wpfcWpfcAjaxCall(polls);
});
</script>		<script>
( function ( body ) {
'use strict';
body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
} )( document.body );
</script>
<div style="display:none">
<div class="grofile-hash-map-29db26da9206fb239e36ba90e51d08d2">
</div>
<div class="grofile-hash-map-29db26da9206fb239e36ba90e51d08d2">
</div>
</div>
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"Article","headline":"StoreDot announces patent for system to reduce EV charge times","url":"https:\/\/www.enginetechnologyinternational.com\/news\/fuel-cells-technologies\/storedot-announces-patent-for-system-to-reduce-ev-charge-times.html","image":{"@type":"ImageObject","url":"https:\/\/www.enginetechnologyinternational.com\/wp-content\/uploads\/2021\/08\/ETM-Web-August-25-StoreDot.jpg","width":700,"height":335},"datePublished":"2021-08-25T12:33:26+01:00","dateModified":"2021-08-25T12:33:26+01:00","author":{"@type":"Person","name":"Callum Brook-Jones"},"publisher":{"@type":"Organization","name":"Engine + Powertrain Technology International","logo":{"@type":"ImageObject","url":"https:\/\/www.enginetechnologyinternational.com\/wp-content\/uploads\/2019\/06\/engine_powertrain.png"}},"mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.enginetechnologyinternational.com\/news\/fuel-cells-technologies\/storedot-announces-patent-for-system-to-reduce-ev-charge-times.html"}}</script>
<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};var tribe_system_info = {"sysinfo_optin_nonce":"b4243a0950","clipboard_btn_text":"Copy to clipboard","clipboard_copied_text":"System info copied","clipboard_fail_text":"Press \"Cmd + C\" to copy"};/* ]]> */ </script><!-- <link rel='stylesheet' id='so-css-smartmag-css'  href='https://www.enginetechnologyinternational.com/wp-content/uploads/so-css/so-css-smartmag.css?ver=1552579438' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//www.enginetechnologyinternational.com/wp-content/cache/wpfc-minified/8hs2t0ee/htnqo.css" media="all"/>
<script type='text/javascript' src='https://www.enginetechnologyinternational.com/wp-includes/js/comment-reply.min.js?ver=ac5b09b99a0ec7d5ed3594f9ff954106'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=202134'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/www.enginetechnologyinternational.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.enginetechnologyinternational.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.2'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2021Augaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.enginetechnologyinternational.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=ac5b09b99a0ec7d5ed3594f9ff954106'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var Bunyad = {"ajaxurl":"https:\/\/www.enginetechnologyinternational.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.enginetechnologyinternational.com/wp-content/themes/smartmag/js/bunyad-theme.js?ver=3.1.0'></script>
<script type='text/javascript' src='https://www.enginetechnologyinternational.com/wp-content/themes/smartmag/js/jquery.flexslider-min.js?ver=3.1.0'></script>
<script type='text/javascript' src='https://www.enginetechnologyinternational.com/wp-content/themes/smartmag/js/jquery.sticky-sidebar.min.js?ver=3.1.0'></script>
<script type='text/javascript' src='https://www.enginetechnologyinternational.com/wp-includes/js/wp-embed.min.js?ver=ac5b09b99a0ec7d5ed3594f9ff954106'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202134.js' async='async' defer='defer'></script>
<script type='text/javascript'>
_stq = window._stq || [];
_stq.push([ 'view', {v:'ext',j:'1:7.1.3',blog:'144612661',post:'10990',tz:'1',srv:'www.enginetechnologyinternational.com'} ]);
_stq.push([ 'clickTrackerInit', '144612661', '10990' ]);
</script>
<style type="text/css"></style><script src="https://www.ukimediaevents.com/publication/js/smart-app-banner.js" type="text/javascript"></script>
<script>new SmartBanner({title:'Engine Technology International', author:'UKi Media & Events'});</script>
</body>
</html><!-- WP Fastest Cache file was created in 1.6112718582153 seconds, on 25-08-21 12:33:34 -->